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Abstract
The following will be discussed:
• Enhancements in *CONTROL_FORMING_ONESTEP
• Smoothing of strain ratio (β) for failure prediction under nonlinear strain paths, with
*CONTROL_ FORMING_TOLERANC
• “Soft 6” contact improvement for gage pin contact
• Weld line mapping with *INTERFACE_WELDLINE_DEVELOPMENT
• Improvements in *BOUNDARY_SPC_SYMMETRY_PLANE (SET)
• Improvements in springback compensation
• Improvements in *ELEMENT_LANCING

Enhancements in *CONTROL_FORMING_ONESTEP
When one-step forming method was first introduced back in 2011, all quadrilateral elements in the model were
split into two triangular elements internally for calculation. As of Dev112682, this original formulation (with
no option) is set as option TRIA. A new option QUAD (one integration point in plane, Dev112071) is now
available supporting quadrilateral elements, and with improved algorithm in various areas, which leads to better
results. In addition, this option greatly improves calculation speed under multiple CPUs in SMP mode.
Another new option QUAD2 (four integration points in plane) improves upon the option QUAD with fully
integrated element formulation, which further improves results in terms of thinning and plastic strain with
slightly longer CPU times.
Results in Figure 1, Figure 2 and Figure 3 show thickness and effective plastic strain contour plots for option
TRIA, QUAD and QUAD2, respectively. In the areas marked, both thickness and plastic strains are better in
QUAD2 than the other options.
Performance comparisons among the three options can be found in Table 1. The option QUAD2 is set as the
default option as of Revision 112682 and is the recommended option.
On a general note, more stretch in the part could be achieved by using the option _DRAWBEAD. In addition,
process parameters, such as blank size (final blank shape) should be carefully considered to achieve a realistic
one-step simulation results.
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Thickness (mm)

Effective plastic strain

Figure 1 Results from the original option TRIA.

Thickness (mm)

Effective plastic strain

Figure 2 Results from option QUAD
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Thickness (mm)

Effective plastic strain

Figure 3 Results from option QUAD2

Table 1 Computing performance comparison of various options.
Calculation speed (D.P. SMP Rev.112720, 8 CPUs)

Number
of
elements

Option TRIA

Option QUAD

Option QUAD2

A hat shaped part

71000

21.0 min

14.1 min

16.6 min

An upper dash panel

61700

24.5 min

11.5 min

17.2 min

Smoothing of Strain Ratio (β) with *CONTROL_FORMING_TOLERANC
Formability Index (F.I.) is used to assess sheet metal formability (necking failure). Explicit dynamic analysis
introduces noises in strain ratio (minor/major strain increment) calculation affecting the F.I. values. A new
keyword *CONTROL_FORMING_TOLERANC was developed jointly with the Ford Motor Company, to
address the issue.
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The incremental change of in-plane major and minor strains are smoothed according to the following formula:
∆𝜖𝜖1(𝑛𝑛−1) ∗ (1 − 𝛼𝛼) + 𝑑𝑑𝜖𝜖1(𝑛𝑛) ∗ 𝛼𝛼
∆𝜖𝜖2(𝑛𝑛−1) ∗ (1 − 𝛼𝛼) + 𝑑𝑑𝜖𝜖2(𝑛𝑛) ∗ 𝛼𝛼

where, 𝑑𝑑𝜖𝜖1(𝑛𝑛) and 𝑑𝑑𝜖𝜖2(𝑛𝑛) are incremental changes of 𝜖𝜖1 and 𝜖𝜖2 in the current time step n, ∆𝜖𝜖1(𝑛𝑛−1) and
∆𝜖𝜖2(𝑛𝑛−1) are incremental changes of 𝜖𝜖1 and 𝜖𝜖2 in the previous time step n-1. The weighting coefficient 𝛼𝛼
regulates the smoothness of the incremental changes in 𝜖𝜖1 and 𝜖𝜖2.

Strain ratio 𝛽𝛽 results from smoothed incremental major and minor strains and stored in history variable #2 along
with additional information (see Table 2 for details) in “.o” file if running in a batch queueing system, or
directly dumped onto the screen if running in an interactive window.
𝛽𝛽 =

∆𝜖𝜖2(𝑛𝑛−1) ∗ (1 − 𝛼𝛼) + 𝑑𝑑𝜖𝜖2(𝑛𝑛) ∗ 𝛼𝛼
∆𝜖𝜖1(𝑛𝑛−1) ∗ (1 − 𝛼𝛼) + 𝑑𝑑𝜖𝜖1(𝑛𝑛) ∗ 𝛼𝛼

The upper limit of 𝛽𝛽 is set at 1.0 while the lower limit is:
−

where 𝑟𝑟̅ is the anisotropic parameter:

𝑟𝑟̅ =

𝑟𝑟̅
1 + 𝑟𝑟̅

𝑟𝑟0 + 2𝑟𝑟45 + 𝑟𝑟90
4

where 𝑟𝑟0 , 𝑟𝑟45 and 𝑟𝑟90 are Lankford parameter in the rolling, diagonal and transverse direction, respectively.

The keyword is applicable to *MAT_036, *MAT_037, *MAT_125, *MAT_226, with the nonlinear strain path
option (NLP). History variables are summarized below for *MAT_036, *MAT_037, *MAT_226:
#1 - F.I.
#2 - β (strain ratio)
#3 - effective plastic strain
For *MAT_125, history variables are designated as follows:
#24 - F.I.
#25 - β (strain ratio)
#26 - effective plastic strain
As shown in Figure 4, beta smoothed using smoothing algorithm is much better than unsmoothed one. Most
importantly, a plot of strain path (Figure 5) in the traditional FLD space (𝜖𝜖1 vs. 𝜖𝜖2) confirms the terminal beta is
approximately 0.9, which is much closer to the smoothed beta value (Figure Error! Reference source not
found.) at the end of the simulation.
Table 2 “.o” file output information and positions. Note only the mid-IP information are output.
Output
items

IP #

Element ID

Time

β

Columns

1st to 8th

9th to18th

19th to 29th

30th to 40th
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Figure 4 Effect of smoothing on strain ration β

Figure 5 Strain path and terminal strain ratio β value.

“Soft 6” Contact Improvement for Gage Pin Contact
Contact option SOFT=6 can be activated in *CONTACT_... Optional Card A, using the variable SOFT. This
specialized contact treatment addresses contact issues in situation where blank gage pins are narrow or small
and blank mesh are coarse (Figure 6), leading to missing contact in some cases. This feature applies to gravity
loading and forming of sheet blank with mesh, and for use with *CONTACT_FORMING_NODES_TO_
SURFACE only. In addition, the variable ORIENT in *CONTROL_CONTACT must be set to “4”. Currently
this feature is available in double precision, SMP only, starting in Revision 81297 and later releases.
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Nodes along the entire or a portion of the blank edge to be contacted with gage pins must be included in a node
set for the variable SSID in *CONTACT_FORMING_NODES_TO_SURFACE (Figure 7 left). The nodes in
the node set must be listed in a consecutive order, as defined “by path” in LSPP4.3, under Model → CreEnt →
Cre → Set Data → *SET_NODE. Note there is no thickness existing for either the blank edge or the gage pins.
Starting in Revision 110072, SSID in *CONTACT_FORMING_NODES_TO_SURFACE can be input as part ID
of the blank, making it much easier to use SOFT=6.
In an example shown in Figure 7, a gage pin goes right through the blank edge without the use of the option.
Using the option, the blank edge stops the gage pin correctly, in Figure 8.
IMPROVEMENT #1 (Revision 109342). Instead of defining a node set using SSTYP=4, an SSTYP of 3 (a
part PID, not the part set ID) can also be used for the SSID, simplifying the definition of contact interfaces for
SOFT=6.
IMPROVEMENT #2 (Revision 118623). Certain coarse blank mesh causes an initial contact penetration
between blank gaging hole edge and the gaging pin mesh. Additional nodes will be created on the blank along
the hole edge and then moved to clear the initial penetration with the gage pin, as shown in Figure 9.

Figure 6 Gage pin contact issue.
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Figure 7 Missing contact without SOFT=6.

Figure 8 Contact captured with SOFT=6.
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Figure 9 Removal of initial penetration between gage pin and blank edge.

Weld Line Mapping with *INTERFACE_WELDLINE_DEVELOPMENT
In forming of tailor welded blanks, an initial straight weld line could become a curve on the formed part. The
amount of deviation of the formed weld curve from its initial line depends on the part shape and forming
conditions. Sometimes the formed weld curve is not desirable; so a correction to the initial weld curve is
needed. This feature allows for determination of the final weld curve given the initial weld curve and viceversa without performing another simulation. Mesh with adaptivity for the initial blank and final part is
supported.
Preparation of the final (formed) weld curve may involve its projection onto the final blank mesh if it does not
exactly lie on the mesh surface. This can be done with LS-PrePost® 4.2 via the menu option GeoTol → Project
→ Project, select Closest Projection, select Project to Elements, then define the destination mesh and source
curves, and hit Apply. Sometimes the target curve may need enough points before projection; the points may be
added via menu option Curve → Spline → Method (Respace) → by number. To write the curve out in
*DEFINE_CURVE_TRIM_3D format, use Curve → Convert → Method (To DEFINE_CURVE_TRIM) → To
Key, then write out the keyword using FILE → Save Keyword.
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Computed weld curves are written with *DEFINE_CURVE_TRIM_3D keyword into a file called weldline.ibo
(or, weldline_f.ibo, depending on the IOPTION). The format of this file follows the keyword’s specification.
LS-PrePost 4.0 can convert the computed curve to IGES; see the procedure in the manual pages for
*INTERFACE_BLANKSIZE_DEVELOPMENT. After hitting the button Apply, the curves will show up in
the graphics window, and File → Save as → Save Geom as can be used to write the curves out in the IGES
format.
As shown in Figure 10, given the initial (initialblank.k) and final blank (finalblank.k) configuration and a final
formed weld curve (finalweldingcurve.k), the following input calculates a new initial weld curve on the initial
blank. In this case, the final weld curve is specified as straight in the drawn panel.
The output is the initial weld curve in the file weldline.ibo, Figure 10. Nodes of element edges that intersect the
initial weld curve are output in affectednd_i.ibo; while nodes of element edges that intersect the final formed
weld curve are output in affectednd_f.ibo, Figure 11.
To verify the predicted weld curve, the initial blank can be re-meshed according to the curve. A draw
simulation can be performed again to confirm the final weld curve as straight, Figure 12.
Likewise, if given an initial weld curve (initialweldingcurve.k) and a final weld curve (weldline_f.ibo) can also
be calculated.

Figure 10 Calculating initial weld curve from final weld curve.
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Figure 11 Output of affected nodes.

Figure 12 A verification simulation may be needed.
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Improvements in *BOUNDARY_SPC_SYMMETRY_PLANE (SET)
This keyword constrains nodes that are within some distances (a tolerance) of a plane to have no motion
orthogonal to that plane. This keyword is usually used for a geometric symmetry plane, so that the full
geometry does not have to be modeled; and it supports both h- and r-adaptivity.
As shown in Figure 13, a symmetric plane’s position is defined using a point’s coordinates X, Y and Z, and its
orientation is defined by a vector component VX, VY and VZ. All nodes within a specified tolerance with the
variable TOL will be constrained in motion orthogonal to the plane.
Originally designed for metal forming simulation only, the feature has garnered much interests from the users to
the point where many of the initial limitations are removed so it can be applied in many other simulation fields.
Two of the eliminated restrictions are:
1) Only two such (symmetry plane) definitions can be used when the symmetry planes are not parallel to the
global XY, YZ, or ZX planes, and,
2) For multiple symmetry planes, position coordinates defined by the variables X, Y, and Z on all symmetry
planes must have the same values for these fields.
Starting from Dev Revision 124122, multiple symmetric planes can be defined even if they are not aligned with
the global coordinate systems. Each symmetric plane can be defined with distinctive point coordinates.

Figure 13 Defining *BOUNDARY_SPC_SYMMETRY_PLANE_SET
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Improvements in Springback Compensation
New keywords and additional options are made to improve the springback compensation convergence. These
keywords are:
*INTERFACE_COMPENSATION_3D (new variable TANGENT),
*INTERFACE_COMPENSATION_3D_REFINED_RIGID,
*INCLUDE_COMPENSATION_TRIM_NODE,
*INCLUDE_COMPENSATION_TANGENT_CONSTRAINT.
Compensation of flanging tools is now possible with the keyword *INTERFACE_COMPENSATION_
FLANGE.
Trim Lines Alignment
As shown in Figure 14 (top) and Figure 15 (top middle), rigid bodies that represent stamping tools often are
meshed across the trim lines; as such, trim lines could lie right in the middle of large elements, and this is
especially true in small curvature areas. In this situation, since there are no nodes right along the trim lines
there, the compensated mesh do not conform to the trim lines. This leads to errors in springback error (Figure
15 bottom) in the subsequent dies and therefore affecting the compensation convergence. The following
keyword *INTERFACE_COMPENSATION_3D_REFINE_RIGID
refines the rigid body elements and aligns the nodes in the tool mesh (Figure 14 bottom, Figure 16 top and
Figure 17 bottom) with the provided trim curves defined using *DEFINE_CURVE_TRIM_3D. The refined
rigid tool mesh will be output as rigid_refined.tmp, which can be used to start the iterative springback
compensation process, leading to a much successful compensation. The aligned nodes will also be output in a
file named bndnd0.tmp.
Maintain Tangency
To improve the tangency that must be maintained between the addendum and binder (Compensation Method 7,
refer to Keyword User’s Manual I under *INTERFACE_COMPENSATION_3D) in the draw die, and
tangential transitions immediately off the rigid tool at the trim curve area to the addendum, a new variable
TANGENT is added, and it must be set to “1”. In the keyword example below, the rigid_refined.tmp (a
resulting file from the option REFINE_RIGID) is used as both the current and the original tool. The aligned
nodes file bndnd0.tmp is used under the new keyword *INCLUDE_COMPENSATION_TRIM_NODE, which
is used for tangency calculation.
Note the variable TANGENT replaces the keyword
*INCLUDE_COMPENSATION_TANGENT_CONSTRAINT, which was initially developed to do a similar
job.
In Figure 15 (top left), compensated die (in yellow) is not tangent to the binder at the die radius. Using the
option TANGENT, the same area has maintained tangency after the compensation, in Figure 16 (left) and
Figure 17 (left). Similarly, Figure 16 (top right) shows addendum transition off the trim lines is not smooth
(kinky); while the tangency is fully maintained in the same area using the option TANGENT, in Figure 16
(bottom) and Figure 17 (bottom right).
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Compensation of Flanging Process with option FLANGE
This new capability is developed specifically to compensate multiple flanging tools for springback in a flanging
process. Currently a maximum of two flanging steels in the same process can be defined. Ash shown in Figure
18, each flanging steel’s moving direction can be defined by a vector component [Vx, Vy, Vz]. The flanging
post can be selected as the master tool surface mesh and the flanging steels are compensated while maintaining
the necessary tool gaps as in the original, uncompensated tool mesh. Note in the compensation of flanging
process the requirement on the even tool gap everywhere is removed, so flanging steels do not have to follow
the flanging post, for example in the flanging steel radius area, etc.

Figure 14 Rigid tool mesh do not align with trim lines.
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Figure 15 Tool mesh does not conform to nominal surface along the trim lines, leading to springback
error in the subsequent die.

Figure 16 Rigid tool mesh do not cross trim lines and addendum remains tangent to the binder.
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Figure 17 Improved rigid tool compensation geometry

Figure 18 Compensation of flanging die using option FLANGE.
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Improvements in *ELEMENT_LANCING
Keywords: *ELEMENT_LANCING, and *DEFINE_CURVE_TRIM_3D can be invoked to conduct lancing
operation. With keyword *ELEMENT_LANCING, both instant and progressive lancing can be simulated. The
keyword *DEFINE_CURVE_TRIM_3D can be used to define lancing curves. There are several limitations
with the original implementation:
1) Only 1 part (PID) is allowed,
2) Only X, Y, Z data pairs are allowed to define lancing curves,
3) No adaptive refinement along lancing route,
4) Lanced scraps cannot be removed,
5) Onset of lancing cannot be defined directly using distance from punch bottom.
Enhancements are made to remove the limitations:
1) A part set is now allowed, which enables lancing across tailor-welded blanks, shown in Figure 21,
2) IGES format curves can now be used as input to define the lancing route,
3) Mesh along the lanced boundary is now automatically adapted to provide a smooth edge, in Figure 20, and
Figure 21,
4) Trimming now can be defined after lancing to remove the scrap. This is done by define a seed point
indicating the remaining part after trimming, with the new keyword *DEFINE_LANCE_SEED_POINT_
COORDINATES, Figure 19.
5) Lancing activation distance can now be defined using a new variable CIVD.
As additional requirements arises from our users, this feature will be continuously improved in the future.

References
LS-DYNA User’s Manual I.
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Figure 19 Lancing with trimming.

Figure 20 Automatic mesh refinement along lancing route.

Figure 21 Lancing across laser welded line and automatic mesh refinement along lancing route.
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